Pokaż wyniki od 1 do 3 z 3
  1. #1

    Dołączył
    Jan 2008
    Mieszka w
    Warszawa

    Domyślnie Flight Gear 1.0.0 - Unknown exception, okresowe spowolnienia


    Polecamy

    Zainstalowałem wersję 1.0.0 Mam problem - bardzo często przy próbie uruchomienia symulatora, po wybraniu samolotu i lotniska, po naciśnięciu RUN i całym procesie odpalania pojawia mi się komunikat:

    Kod:
    Unknown exception in the main loop. Aborting...
    Co mogę na to poradzić?
    Np. Ani razu nie udało mi sie uruchomić Cessny 172P. A widzę, że jest polecana jako mocno realistyczna. Działa mi 787, ale też nie zawsze się uruchamia.

    Czy może lepiej pobrać i zainstalować starszą wersję? Jak już ruszy to działa stabilnie, ale....

    no właśnie jest ale. Czasami długo jest po kilkadziesiąt klatek na sekundę a potem zwalnia do 1..2..4 klatek na sekundę. Wylądować przy tak wolnym odświeżaniu obrazu nie sposób.
    Nie wiem czemu tak się dzieje. Zauważyłem, że czasami pomaga wciśnięcie pauzy, poczekanie kilkunastu sekund oraz wyłączenie pauzy. Czasami jednak to nic nie zmienia. Z obserwacji uruchomionych procesów wynika, że Flight Gear zjada 97% czasu procesora - więc to chyba nic innego nie zamula tak.

    Nie ma stanów pośrednich - albo jest płynnie i dobrze albo się psuje. Próbowałem zmniejszać rozdzielczość, usuwać z renderingu co się da i nic. Co ciekawe potrafi chwilę pomulić i potem przyspieszyć.

    Mam PM 1.6GHz z 2MB cache. 1 GB ram. Kartę ATi Radeon na notebooku (ThinkPad R51).

    Tak nawiasem mówiąc odnośnie tego symulatora to szkoda, że nie ma jakiegoś samolotu z bardziej czytelną kabiną (większe i wyraźne wskaźniki - nie muszą być koniecznie stylizowane na fotografię). W sumie zależy mi tylko na realizmie lotu. Najbardziej mi się podoba kabina bociana Wszystko duże i wyraźne. I miło się nim lata. Można lądować nawet poza lotniskami
    Ostatnio edytowane przez Rafalik ; 14-07-2010 o 20:46
    Piotr

  2. #2

    Dołączył
    Jan 2008
    Mieszka w
    Warszawa

    Domyślnie

    Sam sobie odpowiadam - może komuś się przyda.

    Co do "Unknown exception" - nic nie wiem - sam przestał się pojawiać tak samo jak zaczął.

    Co do okresowych spowolnień być może znalazłem problem. Być może - bo nie wiem czy źródło tych spowolnień jest jedno czy więcej. Otóż jak się włączy 3D clouds to czasami jakieś śmieci zostają w OpenGL - nawet po wyłączeniu i włączeniu symulatora (tak znalazłem na forum ze strony projektu). Trzeba uruchomić symulator, z opcji View wyłączyć 3D Clouds, wyłączyć symulator i włączyć ponownie (z 3D clouds lub nie - nie ma znaczenia). Faktycznie to działa.

    Jak śmieci brak i symulator prawidłowo używa sprzętowego wspomagania, to na każdych, nawet najbardziej obciążających ustawieniach z moim notebookiem działa płynnie.
    Piotr

  3. #3

    Dołączył
    Jan 2008
    Mieszka w
    Warszawa

    Domyślnie


    Polecamy

    Prowadzę tu taki monolog sam ze sobą - ale może komuś się przyda.

    Doszedłem wczoraj o co chodzi z tym "Unknown exception...". Występuje przy nieprawidłowo zbudowanym pliku xml do joysticka, jeżeli joystick jest podłączony. Otóż jak się używa programu fgjs do wygenerowania parametrów dla joysticka (specjalnie kupiłem do symulatora) to on w pliku xml jeżeli występuje parametr tagu równy 0 to poprostu go nie wpisuje. Dopisałem ręcznie. Natomiast w sekcji obsługi view jest zbędna sekcja binding zawierająca tylko factor - usunąłem. Wszystko teraz działa rewelacyjnie. Szybko i za każdym razem.
    Piotr

LinkBacks (?)


Uprawnienia umieszczania postów

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •